Seguro que no notas nada al leer esta entrada, pero te aseguro que detrás hay muchos, muchos cambios. Para empezar, la versión 2.1 de WordPress, el software sobre el que se basa este blog, en lugar de la 2.0.7 que habí­a instalada hasta ayer. Y aunque parece un cambio menor, me ha costado casi un dí­a entero poder cambiar de versión.

Y el problema no ha estado en WordPress, porque los cambios de versión no cuelen llevar más de 5 ó 10 minutos una vez que le coges el truco al asunto. El problema esta vez ha venido de conseguir cumplir los requisitos de la nueva versión, en particular conseguir instalar la versión 4.x de MySQL.

Cuando la semana pasada vi el anuncio de la nueva versión de WordPress, me dije “¡Esta es la mí­a”, porque la lista de nuevas funcionalidades incluí­a algunas muy golosas, especialmente el auto guardado de las entradas mientras las escribes (por lo que pueda pasar), corrector ortográfico (que he conseguido hacer funcionar en castellano, aunque haciendo trampas), y un mejor rendimiento (eso sí­ se nota, y mucho).

Pues nada,que me voy a la página de descarga, en la que pone “no instales sin cumplir los prerrequisitos”, que son unas versiones recientitas de PHP y MySQL (al menos la 4.0). Rapidito, rapidito, me voy al servidor donde tengo alojado el blog, miro la versión de MySQL…. la 3.23. Lo que sigue no es válido para “no iniciados” en esto de Linux…

Primer ataque: instalación a capón del paquete con la versión 4.1. Resultado: sonrisita del sistema como diciendo “¿estás intentando reproducir un CD en un tocadiscos?”. Y a partir de ahí­ vino la debacle.

Resulta que el servidor en cuestión lo contraté allá por finales de 2003, y vení­a instalada de serie la distribución Red Hat Enterprise Linux 3, recientita para la época pero un poco anticuada ya. Así­ que me ha tocado actualizarla, pasito a pasito, y pegándome unas leches de impresión. No he restaurado tantas veces las copias de seguridad en mi vida. Lo que parecí­a algo sencillo ha costado doce horas, dos actualizaciones intermedias (actualización a los paquetes más recientes de RHEL 3, de ahí­ a CentOS 3, y luego a CentOS 4.4) y siete restauraciones de backup. Resulta que estos cambios a lo bestia nunca salen bien. Por suerte pude instalar al principio una buena versión de yum. Lo malo es que a veces reventaba porque algún paquete no se actualizaba bien, y habí­a que arreglarlo a mano. O desaparecí­an los dispositivos en /dev porque el núcleo del servidor virtual no era compatible con el paquete udev que se instalaba, y a partir de ahí­ te quedabas sin SSH…

En fin, que nunca más. A partir de ahora, actualizaciones regulares, que ya se sabe que si no el trabajo se acumula y no hay quien lo saque del derecho.

Tags:

Deja un comentario

Si lo deseas, puedes usar estas etiquetas HTML: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>